# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*(=?)\s*foo(?!\s*=)/$1bar/gm;t' <<< "1) foo=foo
2) foo = foo
3) (foo)=foo "