use strict;
my $str = '1) foo=foo
2) foo = foo
3) (foo)=foo ';
my $regex = qr/\s*(=?)\s*foo(?!\s*=)/mp;
my $subst = '$1bar';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";