re = /\s*(=?)\s*foo(?!\s*=)/m
str = '1) foo=foo
2) foo = foo
3) (foo)=foo '
subst = '$1bar'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result