$re = '/\s*(=?)\s*foo(?!\s*=)/m';
$str = '1) foo=foo
2) foo = foo
3) (foo)=foo ';
$subst = "$1bar";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;