#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!=)(=[^=]+=)(?!=)"
Local $sString = "=This is title= ==This is subtitle== ===This is sub sub title==="
Local $sSubst = "=\1="
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)