re = /(?<!=)(=[^=]+=)(?!=)/m
str = '=This is title= ==This is subtitle== ===This is sub sub title==='
subst = '=\\1='
result = str.gsub(re, subst)
# Print the result of the substitution
puts result