$re = '/(?<!=)(=[^=]+=)(?!=)/m';
$str = '=This is title= ==This is subtitle== ===This is sub sub title===';
$subst = "=\1=";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;