use strict;
my $str = '=This is title= ==This is subtitle== ===This is sub sub title===';
my $regex = qr/(?<!=)(=[^=]+=)(?!=)/mp;
my $subst = '=\\1=';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";