const regex = /(?:\bserial 7's |\G(?!^))-?\K\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\bserial 7\'s |\\G(?!^))-?\\K\\d+', 'gm')
const str = `serial 7's 93-86-79-72-65 very slow, recall 3/3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}