import re
regex = re.compile(r"(?:\bserial 7's |\G(?!^))-?\K\d+", flags=re.MULTILINE)
test_str = "serial 7's 93-86-79-72-65 very slow, recall 3/3"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")