$re = '/(?:\bserial 7\'s |\G(?!^))-?\K\d+/m';
$str = 'serial 7\'s 93-86-79-72-65 very slow, recall 3/3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);