re = /(?:\bserial 7's |\G(?!^))-?\K\d+/m
str = 'serial 7\'s 93-86-79-72-65 very slow, recall 3/3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end