using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Z]:?\d+(GB|gb),( [A-Z]:?\d+(GB|gb)){2}$";
string input = @"C:64GB, F:128GB H:32GB
C:64gb, F:128GB H:32gb
C:64gb F:128GB H:32gb
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}