re = /^[A-Z]:?\d+(GB|gb),( [A-Z]:?\d+(GB|gb)){2}$/m
str = 'C:64GB, F:128GB H:32GB
C:64gb, F:128GB H:32gb
C:64gb F:128GB H:32gb
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end