const regex = /^[A-Z]:?\d+(GB|gb),( [A-Z]:?\d+(GB|gb)){2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Z]:?\\d+(GB|gb),( [A-Z]:?\\d+(GB|gb)){2}$', 'gm')
const str = `C:64GB, F:128GB H:32GB
C:64gb, F:128GB H:32gb
C:64gb F:128GB H:32gb
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}