$re = '/^[A-Z]:?\d+(GB|gb),( [A-Z]:?\d+(GB|gb)){2}$/m';
$str = 'C:64GB, F:128GB H:32GB
C:64gb, F:128GB H:32gb
C:64gb F:128GB H:32gb
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);