package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:#capture)(\s*batman (\d+) batman\s*)*(?:#capture)`)
var str = `#capture
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#capture
#others
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#others`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}