const regex = /(?:#capture)(\s*batman (\d+) batman\s*)*(?:#capture)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:#capture)(\\s*batman (\\d+) batman\\s*)*(?:#capture)', 'g')
const str = `#capture
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#capture
#others
batman 12345 batman
batman 234 batman
batman 35655 batman
batman 1311 batman
#others`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}