import re
regex = re.compile(r"(?:#capture)(\s*batman (\d+) batman\s*)*(?:#capture)")
test_str = ("#capture\n"
"batman 12345 batman\n"
"batman 234 batman\n"
"batman 35655 batman\n"
"batman 1311 batman\n"
"#capture\n\n"
"#others\n"
"batman 12345 batman\n"
"batman 234 batman\n"
"batman 35655 batman\n"
"batman 1311 batman\n"
"#others")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")