# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(a|h1)\b.*?<\/\1>(*SKIP)(*F)|<(img)[^>]*>(*SKIP)(*F)|(\b222.*?\b)/<a href="#link">\2<\/a>/gsi;t' <<< "<p>111 222 333</p>
<li>111 222 333</li>
<h1>111 222 333</h1>
<h2>111 222 333</h2>
<strong>111 222 333</strong>
<p><strong>111 222 333</strong></p>
<p>111 <a href=\"\">222</a> 333</p>
<img src=\"image.png\" alt=\"222\">
<p>111 222 <img src=\"image.png\" alt=\"222\"> 333 222</p>"