use strict;
my $str = '<p>111 222 333</p>
<li>111 222 333</li>
<h1>111 222 333</h1>
<h2>111 222 333</h2>
<strong>111 222 333</strong>
<p><strong>111 222 333</strong></p>
<p>111 <a href="">222</a> 333</p>
<img src="image.png" alt="222">
<p>111 222 <img src="image.png" alt="222"> 333 222</p>';
my $regex = qr~<(a|h1)\b.*?</\1>(*SKIP)(*F)|<(img)[^>]*>(*SKIP)(*F)|(\b222.*?\b)~sip;
my $subst = '<a href="#link">\\2</a>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";