import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(a|h1)\\b.*?</\\1>(*SKIP)(*F)|<(img)[^>]*>(*SKIP)(*F)|(\\b222.*?\\b)";
final String string = "<p>111 222 333</p>\n"
+ "<li>111 222 333</li>\n"
+ "<h1>111 222 333</h1>\n"
+ "<h2>111 222 333</h2>\n"
+ "<strong>111 222 333</strong>\n"
+ "<p><strong>111 222 333</strong></p>\n"
+ "<p>111 <a href=\"\">222</a> 333</p>\n"
+ "<img src=\"image.png\" alt=\"222\">\n"
+ "<p>111 222 <img src=\"image.png\" alt=\"222\"> 333 222</p>";
final String subst = "<a href=\"#link\">\\2</a>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}