#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[1-9]\d{3,}|9[6-9]\d|9[5-9]{2}"
Local $sString = "111" & @CRLF & _
"55" & @CRLF & _
"954" & @CRLF & _
"955" & @CRLF & _
"1000" & @CRLF & _
"0004" & @CRLF & _
"999999"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")