$re = '/[1-9]\d{3,}|9[6-9]\d|9[5-9]{2}/';
$str = '111
55
954
955
1000
0004
999999';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);