using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[1-9]\d{3,}|9[6-9]\d|9[5-9]{2}";
string input = @"111
55
954
955
1000
0004
999999";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}