import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bobject-group\\b\\S*(?:\\s+(?!object-group\\b)\\S*)*";
final String string = "object-group network FTP\n"
+ " description FTP Access\n"
+ " network-object host BCD1\n"
+ " network-object host BCD2\n"
+ "object-group network NTP\n"
+ " description NTP Access\n"
+ " network-object host ABC1\n"
+ " network-object host ABC2\n"
+ " network-object host ABC3\n"
+ "object-group service sample_service tcp\n"
+ " description Ports 1 2 3\n"
+ " port-object range 80 81\n"
+ " port-object eq pop3\n"
+ " port-object eq imap4\n"
+ " port-object range 443 444\n"
+ "object-group service 8080 tcp\n"
+ " description Servers";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}