import re
regex = re.compile(r"\bobject-group\b\S*(?:\s+(?!object-group\b)\S*)*")
test_str = ("object-group network FTP\n"
" description FTP Access\n"
" network-object host BCD1\n"
" network-object host BCD2\n"
"object-group network NTP\n"
" description NTP Access\n"
" network-object host ABC1\n"
" network-object host ABC2\n"
" network-object host ABC3\n"
"object-group service sample_service tcp\n"
" description Ports 1 2 3\n"
" port-object range 80 81\n"
" port-object eq pop3\n"
" port-object eq imap4\n"
" port-object range 443 444\n"
"object-group service 8080 tcp\n"
" description Servers")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")