const regex = new RegExp('\\bobject-group\\b\\S*(?:\\s+(?!object-group\\b)\\S*)*', 'g')
const str = `object-group network FTP
description FTP Access
network-object host BCD1
network-object host BCD2
object-group network NTP
description NTP Access
network-object host ABC1
network-object host ABC2
network-object host ABC3
object-group service sample_service tcp
description Ports 1 2 3
port-object range 80 81
port-object eq pop3
port-object eq imap4
port-object range 443 444
object-group service 8080 tcp
description Servers`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}