#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=From: ).*([\r\n]|\r\n)(?=Sent: ).*([\r\n]|\r\n)(?=To: ).*([\r\n]|\r\n)(?=Subject: ).*$"
Local $sString = "From: ***********************" & @CRLF & _
"Sent: ***********************" & @CRLF & _
"To: ***********************" & @CRLF & _
"Subject: *******************" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"From: Someone" & @CRLF & _
"Sent: Something" & @CRLF & _
"To: Someone else" & @CRLF & _
"Subject: Is secure"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")