const regex = /^(?=From: ).*([\r\n]|\r\n)(?=Sent: ).*([\r\n]|\r\n)(?=To: ).*([\r\n]|\r\n)(?=Subject: ).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=From: ).*([\\r\\n]|\\r\\n)(?=Sent: ).*([\\r\\n]|\\r\\n)(?=To: ).*([\\r\\n]|\\r\\n)(?=Subject: ).*$', 'gm')
const str = `From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************
From: Someone
Sent: Something
To: Someone else
Subject: Is secure`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}