import re
regex = re.compile(r"^(?=From: ).*([\r\n]|\r\n)(?=Sent: ).*([\r\n]|\r\n)(?=To: ).*([\r\n]|\r\n)(?=Subject: ).*$", flags=re.MULTILINE)
test_str = ("From: ***********************\n"
"Sent: ***********************\n"
"To: ***********************\n"
"Subject: *******************\n\n\n"
"From: Someone\n"
"Sent: Something\n"
"To: Someone else\n"
"Subject: Is secure")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")