$re = '/^(?=From: ).*([\r\n]|\r\n)(?=Sent: ).*([\r\n]|\r\n)(?=To: ).*([\r\n]|\r\n)(?=Subject: ).*$/m';
$str = 'From: ***********************
Sent: ***********************
To: ***********************
Subject: *******************
From: Someone
Sent: Something
To: Someone else
Subject: Is secure';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);