using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:([abcd])(?!\w*?\1)){4}\b";
string input = @"abcd - true
bcad - true
abc - false (need all characters)
abbd - false
abcdd - false";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}