re = /\b(?:([abcd])(?!\w*?\1)){4}\b/
str = 'abcd - true
bcad - true
abc - false (need all characters)
abbd - false
abcdd - false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end