$re = '/\b(?:([abcd])(?!\w*?\1)){4}\b/';
$str = 'abcd - true
bcad - true
abc - false (need all characters)
abbd - false
abcdd - false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);