import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:([abcd])(?!\\w*?\\1)){4}\\b";
final String string = "abcd - true\n"
+ "bcad - true\n"
+ "abc - false (need all characters)\n"
+ "abbd - false\n"
+ "abcdd - false";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}