#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/\d{1,2}\b(?![^\/\r\n]\/)"
Local $sString = "ID Flag" & @CRLF & _
"P-MTP00197854/03 X" & @CRLF & _
"P-MTP00197868/02 X" & @CRLF & _
"P-MTP00197882/00 X" & @CRLF & _
"P-HMF00197730 " & @CRLF & _
"WI/B09/077094 " & @CRLF & _
"Q-MTP00197735 " & @CRLF & _
"Q-HMF00199313/0 X" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Q-HMF/23/00199313/0 X"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")