import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\/\\d{1,2}\\b(?![^\\/\\r\\n]\\/)";
final String string = "ID Flag\n"
+ "P-MTP00197854/03 X\n"
+ "P-MTP00197868/02 X\n"
+ "P-MTP00197882/00 X\n"
+ "P-HMF00197730 \n"
+ "WI/B09/077094 \n"
+ "Q-MTP00197735 \n"
+ "Q-HMF00199313/0 X\n\n\n"
+ "Q-HMF/23/00199313/0 X";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}