$re = '/\/\d{1,2}\b(?![^\/\r\n]\/)/m';
$str = 'ID Flag
P-MTP00197854/03 X
P-MTP00197868/02 X
P-MTP00197882/00 X
P-HMF00197730
WI/B09/077094
Q-MTP00197735
Q-HMF00199313/0 X
Q-HMF/23/00199313/0 X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);