using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*?(?:g31|g32)(?!.*?(?:g21|g22)).*?(?:g11|g12).*$";
string input = @"g31 a bunch of anything or nothing g11
g31g11
g31 a bunch of anything or nothing g21 a bunch of anything or nothing g11
g31g21g11";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}