$re = '/^.*?(?:g31|g32)(?!.*?(?:g21|g22)).*?(?:g11|g12).*$/m';
$str = 'g31 a bunch of anything or nothing g11
g31g11
g31 a bunch of anything or nothing g21 a bunch of anything or nothing g11
g31g21g11';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);