const regex = /^.*?(?:g31|g32)(?!.*?(?:g21|g22)).*?(?:g11|g12).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?(?:g31|g32)(?!.*?(?:g21|g22)).*?(?:g11|g12).*$', 'gm')
const str = `g31 a bunch of anything or nothing g11
g31g11
g31 a bunch of anything or nothing g21 a bunch of anything or nothing g11
g31g21g11`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}