import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^G[01](\\h+X(-?\\d*\\.?\\d+))?(\\h+Y(-?\\d*\\.?\\d+))?(\\h+Z(-?\\d*\\.?\\d+))?(\\h+E(-?\\d*\\.?\\d+))?(\\h+F(\\d*\\.?\\d+))?(\\h*;\\h*([\\h\\w_-]*)\\h*)?";
final String string = "G1 X93.175 Y81.143 E0.70960 ; infill";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}