re = /^G[01](\h+X(-?\d*\.?\d+))?(\h+Y(-?\d*\.?\d+))?(\h+Z(-?\d*\.?\d+))?(\h+E(-?\d*\.?\d+))?(\h+F(\d*\.?\d+))?(\h*;\h*([\h\w_-]*)\h*)?/
str = 'G1 X93.175 Y81.143 E0.70960 ; infill'
# Print the match result
str.match(re) do |match|
puts match.to_s
end