using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(wysija-page=1)(?:&.*)(controller=confirm)(?:.*)(action=subscribe)";
string input = @"http://godoymedical.net/?wysija-page=1&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
http://godoymedical.net/?wysija-page=2&controller=notconfirmed&wysija-key=7b246d4fc4c91968b0529237169787df&action=unsubscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
http://godoymedical.net/?wysija-page=122&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}