use strict;
my $str = 'http://godoymedical.net/?wysija-page=1&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
http://godoymedical.net/?wysija-page=2&controller=notconfirmed&wysija-key=7b246d4fc4c91968b0529237169787df&action=unsubscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
http://godoymedical.net/?wysija-page=122&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
';
my $regex = qr/(wysija-page=1)(?:&.*)(controller=confirm)(?:.*)(action=subscribe)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}