re = /(wysija-page=1)(?:&.*)(controller=confirm)(?:.*)(action=subscribe)/
str = 'http://godoymedical.net/?wysija-page=1&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
http://godoymedical.net/?wysija-page=2&controller=notconfirmed&wysija-key=7b246d4fc4c91968b0529237169787df&action=unsubscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
http://godoymedical.net/?wysija-page=122&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end