import re
regex = re.compile(r"(wysija-page=1)(?:&.*)(controller=confirm)(?:.*)(action=subscribe)")
test_str = ("http://godoymedical.net/?wysija-page=1&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9\n"
"http://godoymedical.net/?wysija-page=2&controller=notconfirmed&wysija-key=7b246d4fc4c91968b0529237169787df&action=unsubscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9\n"
"http://godoymedical.net/?wysija-page=122&controller=confirm&wysija-key=7b246d4fc4c91968b0529237169787df&action=subscribe&wysijap=subscriptions&wysiconf=YToyOntpOjA7czoxOiI0IjtpOjE7czoxOiIzIjt9\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")