package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d\s?(?:\(\d{3}\))?\s?[\d|\-]{8,12})$`)
var str = `1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
and not:
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}