re = /^(\d\s?(?:\(\d{3}\))?\s?[\d|\-]{8,12})$/m
str = '1 (555) 555-5555
5555555555
1 555-555-5555
555-555-5555
and not:
1 555)555-5555
(6505552368)
10 (757) 622-7382
555)-555-5555'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end